Thank you for registering.

Please use the following process to download and install RTI Connext DDS.

The installation files for the RTI Connext DDS Secure 6.0.1 evaluation are provided in a single installer.

Install the Connext host development tools, platform target libraries, and security bundles by executing the host installer application.

  • On Windows systems:
    rti_connext_dds-6.0.1-eval-<Windows_platform>.exe

    On Linux systems:
    rti_connext_dds-6.0.1-eval-<Linux_platform>.run

    On macOS systems:
    rti_connext_dds-6.0.1-eval-<macOS_platform>.dmg

After the installation is complete, start the RTI Launcher application, select the Configuration tab, and set the location of the trial license file that RTI emailed to you.

Upon completing this step, you are ready to evaluate Connext DDS Professional. Visit Getting Started with Connext DDS for great resources and tutorials, as well as the product documentation below:

 

Downloads

By downloading Connext DDS, you acknowledge that you agree to the RTI Software License Agreement.

Linux

 x86 64-bit  x86 32-bit
 REHL 8, Ubuntu 18.04 LTS (kernel 4.x, gcc 7.3.0)  
 Ubuntu 16.04 LTS (kernel 4.x & gcc 5.4.0)   Ubuntu 16.04 LTS (kernel 4.x, gcc 5.4.0)
 RHEL 7, Ubuntu 14.04 LTS (kernel 3.x, gcc 4.8.2)   RHEL 7, Ubuntu 14.04 LTS (kernel 3.x, gcc 4.8.2)
 RHEL 6 (kernel 2.6, gcc 4.4.5)   RHEL 6 (kernel 2.6, gcc 4.4.5)

 

Microsoft Windows

 x86 64-bit  x86 32-bit
 Visual Studio 2017, 2019 (Windows 10, Server 2016)  Visual Studio 2017, 2019 (Windows 10, Server 2016)
 Visual Studio 2015 (Windows 10, Server 2016, Server 2012 R2)  Visual Studio 2015 (Windows 10, Server 2016)

 

macOS

 x86 64-bit
 macOS High Sierra 10.13 (clang 9.0) Mojave 10.14 (clang 10.0)

 

 

Other Platforms

If you are evaluating Connext DDS for use with ROS, please contact your local RTI representative or email sales@rti.com for a compatible evaluation version of Connext DDS. If you would like to evaluate Connext DDS (including Connext DDS Micro) on other operating systems or CPU architectures, please contact your local RTI representative or email sales@rti.com.

 

Software Licensing and Use Terms

Visit www.rti.com/terms for complete product terms and an exclusive list of product warranties. This product includes software developed by the OpenSSL® Project for use in the OpenSSL Toolkit (https://www.openssl.org/). If you are installing the evaluation package of Connext 6.0.1, your installation includes RTI Security Plugins and OpenSSL version 1.1.1d. The installer provides a prebuilt version of OpenSSL 1.1.1d. If you wish to build your own version of OpenSSL 1.1.1d, you can find the source code at the link above (https://www.openssl.org/). Securing a distributed, embedded system is an exercise in user risk management. RTI expressly disclaims all security guarantees and/or warranties based on the names of its products, including Connext DDS Secure and RTI Secure DDS Plugins.